Anyone have any good rules-of-thumb for naming Swift methods? Particularly if there are any tricks to include constraints in the name without the whole method call becoming un-English?
db.setPrimaryKey(of: record, to: key)
db.setPrimaryKeyIfPresent(of: record, to: key) ← weird.
This Mastodon instance is for people interested in technology. Discussions aren't limited to technology, because tech folks shouldn't be limited to technology either!