Follow

Proof that updating the minimum required version () is also part of your public interface and thus a breaking change:

github.com/iqlusioninc/crates/

· · Web · 1 · 0 · 1

@musicmatze I might be lonely in that opinion, but everyone should just always use the latest version and upgrade whenever possible.

I personally would even bump the MSRV in a patch release for any of my crates simply because of that.

I understand not everyone can always use the latest version if on some very special hardware but in general upgrading is a no brainer, especially with rustup.

@dnaka91 it is, especially with nix,... but supporting at least the last three compilers is also a no brainer (yes, I see that 1.51 is in "the last three)...

@musicmatze no there is no way. I have to be on the bleeding edge... Can't resist the temptation... 😂

Sign in to participate in the conversation
Mastodon for Tech Folks

This Mastodon instance is for people interested in technology. Discussions aren't limited to technology, because tech folks shouldn't be limited to technology either!