F!ckn ... outdated freakin ubuntu has packages from the last decade or what?

@musicmatze we had the same problem. We ended up using the latest ubuntu image and are now setting up rustup manually in the ci configuration. Afaik travis is still using xenial for rust builds (check the build log) and setting dist to bionic is ignored. Set `language: minimal` and `dist: bionic` to work around the issue.

mastodon.social/@fin_ger/10260

@musicmatze note: travis is not shipping tmux-2.1 in their bionic image, but rather ignores to use the bionic image and instead is using xenial. I was not aware of that when writing the mentioned toot.

@fin_ger I'm currently investigating running my own build server (buildbot) but this thing is a monster to configure and unfortunately there's no drone service definition for available yet (which my host runs on). I would love to move away from that bs but it's way too hard to configure ci servers IMO.

@musicmatze maybe a temporary solution would be drone in docker? i would also love to have drone as nixos service. might be not so hard to implement... status: github.com/NixOS/nixpkgs/issue

Follow

@davidak does this even work? Because AFAIK you need to be able to run docker for drone, so if you run drone in docker, you need to run docker in docker.

Sounds not like fun.

@musicmatze the official documentation suggest docker and i tested it sucessfully in the past (not on nixos). docs.drone.io/installation/pro

Sign in to participate in the conversation
Mastodon for Tech Folks

The social network of the future: No ads, no corporate surveillance, ethical design, and decentralization! Own your data with Mastodon!