Follow

I'm seeing a lot of discussion over Google's use of an outdated Polymer.js version for YouTube, and its performance under Firefox.

I have some pieces of context:

1. This version of Polymer used the Shadow DOM v0 API.
2. Firefox did not implement the Shadow DOM v0 API, but Chrome did.
3. Firefox and Chrome (and Safari) now both support Shadow DOM v1.
4. This version of Polymer didn't use Shadow DOM v1, as it was developed when the Shadow DOM proposal was still a work-in-progress.

Sign in to participate in the conversation
Mastodon for Tech Folks

This Mastodon instance is for people interested in technology. Discussions aren't limited to technology, because tech folks shouldn't be limited to technology either! We adhere to an adapted version of the TootCat Code of Conduct and follow the Toot Café list of blocked instances. Ash is the admin and is supported by Fuzzface, Brian!, and Daniel Glus as moderators. Hosting costs are largely covered by our generous supporters on Patreon – thanks for all the help!