Follow

Bit of a bad day with ; after multiple releases to get on top of the new requirements by Google (target SDK 28, support 64-bit), hit an issue that broke the app on all pre-Pie versions of Android

PackageInfo.versionCode is deprecated, so it won't build. Use the new version, and it won't run on pre-Pie versions. There's a compatibility package, but to use _that_ you have to update your app to use AndroidX and install Jetifier to hot-patch your node_modules... 😩

Works now. Need 🍺

Sign in to participate in the conversation
Mastodon for Tech Folks

The social network of the future: No ads, no corporate surveillance, ethical design, and decentralization! Own your data with Mastodon!