Follow

Firefox add-ons are fucked because a signing certificate expired.

Expect all your browser add-ons to be broken until they figure out how to fix it. You didn't need that password manager or that facebook container or that ad-blocker did ya? :P

bugzilla.mozilla.org/show_bug.

To be fair, "forgot to renew a cert" happens to all of us, sooner or later. :D

Let's have some sympathy for the bad Friday night some folks are having trying to get it fixed. <3

@brion This is affecting TBB as well. NoScript is no longer enabled there. So this could have some serious real world consequences on the order of prison or worse for some people. It's hard to feel sympathy for the folks at Mozilla right now.

@brion and the page that will get updates is error 429, too many requests

Perhaps this is a plot to become the most popular web site again :)

Sign in to participate in the conversation
Mastodon for Tech Folks

This Mastodon instance is for people interested in technology. Discussions aren't limited to technology, because tech folks shouldn't be limited to technology either! We adhere to an adapted version of the TootCat Code of Conduct and have documented a list of blocked instances. Ash is the admin and is supported by Fuzzface, Brian!, and Daniel Glus as moderators. Hosting costs are largely covered by our generous supporters on Patreon – thanks for all the help!